segunda-feira, 14 de janeiro de 2013

Usando a função PROCV


FUNÇÃO PROCV

Bom dia, boa tarde, boa noite,

Hoje nós vamos falar da função PROCV.
A função PROCV é uma função bastante interessante e útil quando usamos o Excel como Banco de Dados para tabelas e listas. O nome da função é uma “contração” de “PROCura Vertical”.

Basicamente a função PROCV serve para fazer “buscas” de dados e que serão inseridos em algum lugar, com base em uma tabela existente. No nosso exemplo, nós teremos uma tabela de salários praticados para os músicos da fictícia “ORQUESTRA AFINADA”. Você tem uma lista dos salários que serão utilizados em na planilha da folha de pagamento.  Nessa planilha a coluna de salários vai “ler” qual a função do músico e irá retornar na respectiva linha o salário correspondente, “automaticamente”.  

Para ilustrar esta função, vou simular uma busca na folha de pagamento da minha orquestra. Para isso vamos precisar de uma tabela contendo as funções de cada músico e a faixa salarial correspondente.

Tabela de Salários



Assim temos na coluna B as funções dos músicos e na coluna C os salários correspondentes.  Para facilitar nosso trabalha nós vamos criar um nome para essas duas colunas que contém os dados de cargos e salários. Para isso basta clicarmos com o mouse em cima da letra B da planilha e arrastar até a coluna C.



Feito isso basta digitarmos na caixa de nome (conforme a figura 3) um nome para esse banco de dados, no nosso caso eu criei o nome “tabela”.





Dessa forma, o Excel entendeu que a coluna B e C juntas, formam uma área cujo nome é “tabela”.



Em uma outra planilha, dentro da mesma pasta obrigatoriamente, eu realizo o cálculo da minha folha de pagamento, onde o principal valor vai ser o salário base de acordo com o nipe de cada músico.



O que queremos que a planilha execute, é uma busca na tabela de salários e retorne na célula o salário correspondente.  Dito isto, vou mostrar agora a sintaxe da função:

=PROCV(valor_procurado;matriz_tabela;núm_índice_coluna;[procurar_intervalo])

Sendo que:

valor_procurado: indica o valor que você deseja buscar, e que sempre deverá estar na primeira coluna da sua tabela principal de cargos e salários, (a função irá buscar o valor desejado na primeira coluna da tabela de apoio; caso encontre, irá “pegar” esta linha para verificar qual valor irá retornar. Colunas são na vertical, daí o nome da função);

matriz_tabela: é o intervalo onde estão todos os dados que possivelmente sejam usados na tabela principal. No nosso caso, o intervalo será as colunas B até a C. Como já vimos, nós criamos  um nome para esse intervalo, e o chamamos de “tabela” (lembra?).

núm_índice_coluna: indica em qual coluna a função deverá “pesquisar” e retornar o valor caso ache o valor procurado dentro da matriz. Caso desejemos pesquisar a função do músico, o valor será 2 (coluna B é igual a coluna 1 e coluna C – Salários é igual a 2);

[procurar_intervalo]: este item é opcional, e será preenchido com VERDADEIRO ou FALSO. Se deixado em branco, o Excel assumirá que é verdadeiro. Ou seja, você só precisa preencher se quiser que seja FALSO. A diferença entre os dois é que o VERDADEIRO irá pesquisar por valores aproximados, caso não encontre o valor procurado, enquanto que o FALSO busca apenas pelo valor exato procurado. No caso do VERDADEIRO, é necessário que os valores estejam em ordem alfabética crescente (ou numérica crescente). Ou seja, é necessário neste caso classificar os dados.   Os valores a serem colocados são 0 (zero) para Falso e 1 (um) para verdadeiro.



COMO FICOU A NOSSA FÓRMULA?

Vamos escrever a fórmula do PROCV  na nossa célula F7, para que ela nos retorne o valor do salário do músico que está em D7.   



Ficando assim:

=PROCV(D7;tabela;2;0)

E o que significa isso?

=PROCV              é a função procura vertical

D7                         é a célula que contém o valor procurado

tabela                  é o nome que nós demos ao intervalo que compreende as colunas B(1) até a C(2)

2                            é o número as coluna onde deverá ser “capturado” o valor procurado

0 (zero)                Que é o valor para FALSO, ou seja, quero que a coincidência da busca seja exato.

Então na nossa primeira fórmula, o cargo em D7 é o “Maestro”, e pesquisando na tabela, sabermos que um maestro tem um salário base de R$ 15.000,00
Agora é só arrastar a fórmula para buscarmos os demais salários dos membros da orquestra.



Espero poder ter ajudado na compreensão desta poderosa ferramenta do Excel, que é a busca em Banco de Dados. Lembre-se, não importa a quantidade de itens que vocês terão nas suas planilhas, o Excel fará uma busca rápida e precisa.

Escrevam e comentem, isso me ajuda a melhorar o blog.





Abraços a todos.

Charles Hajj




3 comentários:

  1. Charles,
    bom dia, boa tarde, boa noite!
    Seu blog é simplesmente sensacional! Esta de parabéns! Descobri ele recentemente e suas postagens tem me ajudado muito em meu dia a dia no trabalho.

    Gostaria (se não for pedir muito, obviamente), que você faça uma postagem sobre Tabela dinâmica e outra sobre a função SE.

    Desde já agradeço a atenção.

    Abraço,
    William.

    ResponderExcluir
    Respostas
    1. Will, obrigado por suas palavras de motivação.
      A função SE é uma ferramenta poderosa dentro da planilha, ele faz com que ela tome decisões e automatize a planilha. com certeza será uma das funções que serão abordadas no próximo post que deverá contemplar " FOLHA DE PAGAMENTO DE EMPREGADO DOMÉSTICO".
      Mas acredito que o SE é tão importante que mereça um poste exclusivo para ele.
      Quanto a tabela dinâmica, ai a coisa complica, pois a tabela dinâmica é muito complexa e exige análises específicas ou estudo de casos.
      Mas sugestões anotadas.
      Grato
      Charles

      Excluir
    2. Entendido Charles,
      obrigado e abraço!

      Excluir